YetAnotherForum
Welcome Guest Search | Active Topics | Log In | Register

updateInstaller: Fehlermeldung "Unable to find a version of the runtime to run the application&
StefanM Offline
#1 Posted : Thursday, July 12, 2012 10:56:55 AM(UTC)

Rank: Neuling

Joined: 7/12/2012(UTC)
Posts: 5
Points: 15
Hallo,
in einem C# Projekt (.Net Framework 3.5) habe ich updateSystem.Net eingebunden und auch erfolgreich getestet - das sieht soweit sehr gut aus:B

Nur auf einem Testrechner (mit Windows XP) erhalte ich eine Fehlermeldung beim Start des Update-Vorgangs (das Info-Fenster mit dem Hinweis auf das verfügbare Upddate wird angezeigt, ich klicke auf "Ja" und die Anwendung wird dann auch wie üblich geschlossen).

Quote:
updateInstaller.exe - .Net Framework Initialization Error
Unable to find a version of the runtime to run this application.

Das .Net Framework sollte sauber/vollständig installiert sein - sonst würde meine Anwendung auch nicht funktionieren...?
Ich verwende die updateSystemDotNet.Controller.dll in Version 1.5.2.515

Grüße
Stefan
Maximilian Offline
#2 Posted : Thursday, July 12, 2012 5:41:22 PM(UTC)


Rank: Administratoren

Joined: 7/12/2008(UTC)
Posts: 208
Points: 781
Location: Berlin
Hi Stefan :-)

was für ein Framework ist denn auf dem PC installiert auf dem das Problem auftritt? Wenn es nur das .NET Framework 4.0 ist, musst du leider noch das 2.0 oder 3.5 nachinstallieren. Ist ein bisschen blöd aber der einzigste Workaround der derzeit möglich ist.

Viele Grüße,
Maximilian
Maximilian Krauß - updateSystem.NET Lead Developer
Devs-On.Net - Administrator
coffeeInjection.com - Administrator

Bitte für Fehler und Fragen bezüglich des updateSystem.NET nicht mehr das Forum nutzen sondern eine der hier beschriebenen Kontaktmöglichkeiten. Danke!
StefanM Offline
#3 Posted : Thursday, July 12, 2012 8:00:01 PM(UTC)

Rank: Neuling

Joined: 7/12/2012(UTC)
Posts: 5
Points: 15
Mit meiner Anwendung wird das .Net Framework 3.5 installiert (ist auch als Zielframework in den Projekteigenschaften eingestellt).
Kann es sein dass da etwas fehlt? Die Anwendung läuft aber einwandfrei...
Maximilian Offline
#4 Posted : Thursday, July 12, 2012 9:44:38 PM(UTC)


Rank: Administratoren

Joined: 7/12/2008(UTC)
Posts: 208
Points: 781
Location: Berlin
Hmm, .NET 3.5 sollte eigentlich reichen. Ist es das Client Profile oder das komplette? Wenn ersteres installiere bitte noch letzteres :-)

Gruß,
Max
Maximilian Krauß - updateSystem.NET Lead Developer
Devs-On.Net - Administrator
coffeeInjection.com - Administrator

Bitte für Fehler und Fragen bezüglich des updateSystem.NET nicht mehr das Forum nutzen sondern eine der hier beschriebenen Kontaktmöglichkeiten. Danke!
StefanM Offline
#5 Posted : Friday, July 13, 2012 2:10:18 PM(UTC)

Rank: Neuling

Joined: 7/12/2012(UTC)
Posts: 5
Points: 15
Hi Max,

auf dem Rechner sind die folgenden .Net Frameworks installiert:


Viele Grüße
Stefan
Maximilian Offline
#6 Posted : Monday, July 16, 2012 6:05:00 PM(UTC)


Rank: Administratoren

Joined: 7/12/2008(UTC)
Posts: 208
Points: 781
Location: Berlin
Hey Stefan,
das sieht alles soweit eigentlich korrekt aus, ich kann mir den Fehler nicht so wirklich erklären :( Ist das der einzige Rechner an dem dieses Problem auftritt?

Lg,
Max
Maximilian Krauß - updateSystem.NET Lead Developer
Devs-On.Net - Administrator
coffeeInjection.com - Administrator

Bitte für Fehler und Fragen bezüglich des updateSystem.NET nicht mehr das Forum nutzen sondern eine der hier beschriebenen Kontaktmöglichkeiten. Danke!
StefanM Offline
#7 Posted : Thursday, August 30, 2012 10:45:39 AM(UTC)

Rank: Neuling

Joined: 7/12/2012(UTC)
Posts: 5
Points: 15
Hi Max,

wegen Urlaub erst jetzt meine Antwort (sorry):
Der Fehler tritt dann auf, wenn der Anwender _keine_ Adminrechte hat. Mit Adminrechten läuft's problemlos...
(auf mehreren Rechnern getestet)

Viele Grüße
Stefan
Maximilian Offline
#8 Posted : Thursday, August 30, 2012 7:36:24 PM(UTC)


Rank: Administratoren

Joined: 7/12/2008(UTC)
Posts: 208
Points: 781
Location: Berlin
Hey Stefan,
Danke für die Antwort und die Information, ich schaus mir an!

Grüße,
Maximilian
Maximilian Krauß - updateSystem.NET Lead Developer
Devs-On.Net - Administrator
coffeeInjection.com - Administrator

Bitte für Fehler und Fragen bezüglich des updateSystem.NET nicht mehr das Forum nutzen sondern eine der hier beschriebenen Kontaktmöglichkeiten. Danke!
StefanM Offline
#9 Posted : Tuesday, September 18, 2012 10:02:55 AM(UTC)

Rank: Neuling

Joined: 7/12/2012(UTC)
Posts: 5
Points: 15
Hi Max,
hast Du schon etwas herausgefunden?

Ich bin sehr an einer Lösung interessiert ;-)
Kann ich Dich irgendwie bei der Suche nach der Ursache unterstützen?

Danke und viele Grüße
Stefan
Maximilian Offline
#10 Posted : Thursday, September 20, 2012 5:19:33 PM(UTC)


Rank: Administratoren

Joined: 7/12/2008(UTC)
Posts: 208
Points: 781
Location: Berlin
Hey Stefan,
entschuldige die verspätete Antwort aber ich habe momentan recht viel um die Ohren :-/ Das zu testen ist recht aufwändig, da ich zum einen ein XP virtualisieren- und zum anderen den alten Code-Branch heraussuchen muss, in dem dieser Fehler auftritt. Ich habe nächste Woche etwas mehr Luft, da werde ich versuchen dem Problem auf den Grund zu gehen.

Viele Grüße,
Maximilian
Maximilian Krauß - updateSystem.NET Lead Developer
Devs-On.Net - Administrator
coffeeInjection.com - Administrator

Bitte für Fehler und Fragen bezüglich des updateSystem.NET nicht mehr das Forum nutzen sondern eine der hier beschriebenen Kontaktmöglichkeiten. Danke!
Users browsing this topic
Guest (2)
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

TommyB's Skin (Based upon Clean Slate theme by Jaben Cargman (Tiny Gecko))
Powered by YAF 1.9.4 | YAF © 2003-2010, Yet Another Forum.NET
This page was generated in 0,233 seconds.