YetAnotherForum
Welcome Guest Search | Active Topics | Log In | Register

Problem des UpdateInstaller
DoktorAerzt Offline
#1 Posted : Thursday, November 15, 2012 1:29:35 PM(UTC)

Rank: Neuling

Joined: 11/15/2012(UTC)
Posts: 1
Points: 3
Location: Deutschland
Hallo Leute
Ich hab mein Programm fertig gestellt und es funktionier soweit auf meinem Computer. Dann hab ich es auf meinem 2. getestet und auch dort funktioniert es. Auf einen 3. Pc das gleich. Ich habe das Programm dann einen Freund gegeben, bei ihm kommt auch das eine neue Version zur verfügung steht wie bei allen, doch wann bei den anderen immer der "Installer" kommt, da kommt bei ihm nur diese fehlermeldung http://puu.sh/1pu1p
* Ich habe die Version 1.5.2.515 verwendet
*
Quote:

'updateController Objekt initialisieren
Dim updController As New updateSystemDotNet.updateController()
updController.updateUrl = "(ja hier stehen nicht die richtigen daten)"
updController.projectId = "(ja hier stehen nicht die richtigen daten)"
updController.publicKey = "(ja hier stehen nicht die richtigen daten)"

'Releasefilter setzen, per Default wird nur nach finalen Versionen gesucht:
updController.releaseFilter.checkForFinal = True
updController.releaseFilter.checkForBeta = True
updController.releaseFilter.checkForAlpha = True

'Wie soll die lokale Version ermittelt werden?
'updController.retrieveHostVersion = True
'Die Version kann allerdings auch manuell gesetzt werden:
updController.releaseInfo.Version = Label2.Text

'Einfacher Aufruf der Updatesuche:
updController.updateInteractive()

'Anwendung nach dem Update neustarten?
updController.restartApplication = True


Alle Computer haben Win 7 (32 und 64 bit) Bei dem Wo es nicht funktioniert hat 64 bit. Alle Haben Framwork 4.5. Instalation von z.b. 2 nicht möglich.


Dann hätte ich noch eine frage und zwar wenn der Updater das "Instalieren" anfangen will dann Startet immer im hintergrund mein Programm und es kommt ein Error vom Updater das dieser da program nicht vefschieben kann. Wenn man das Programm dann schließt und beim Updater Wiederholen drückt dann kann er auch das update abschließen.

Gruß DoktorAerzt
Maximilian Offline
#2 Posted : Sunday, January 20, 2013 5:01:40 PM(UTC)


Rank: Administratoren

Joined: 7/12/2008(UTC)
Posts: 208
Points: 781
Location: Berlin
Du brauchst das .NET Framework 3.5 oder 2.0 das installiert sein muss, 4.5 alleine reicht nicht, das liegt an einer Kompatibilitätsbrücke von Microsoft auf die ich leider keinen Einfluss habe.

Wegen deines 2. Problems gibts im updateController eine Eigenschaft "autoCloseHostApplication" die du aktivieren musst damit die Anwendung überschrieben werden kann.
Maximilian Krauß - updateSystem.NET Lead Developer
Devs-On.Net - Administrator
coffeeInjection.com - Administrator

Bitte für Fehler und Fragen bezüglich des updateSystem.NET nicht mehr das Forum nutzen sondern eine der hier beschriebenen Kontaktmöglichkeiten. Danke!
Users browsing this topic
Guest
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

TommyB's Skin (Based upon Clean Slate theme by Jaben Cargman (Tiny Gecko))
Powered by YAF 1.9.4 | YAF © 2003-2010, Yet Another Forum.NET
This page was generated in 0,148 seconds.